<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-GB" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
    <title>This Huntress Is Bombarded With Death Threats From Online Trolls | Media Drum World</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://mediadrumworld.com/xmlrpc.php" />
    <link rel="icon" type="image/png" href="https://mediadrumworld.com/wp-content/uploads/2016/08/MDW-LOGO-FINAL-EMAIL.jpg">
<!-- This site is optimized with the Yoast SEO Premium plugin v4.9 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="The huntress is bombarded with death threats from online trolls who say she should be hunted like her animals are. Read more."/>
<link rel="canonical" href="https://mediadrumworld.com/2020/09/10/death-threat-hunting-trolls/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="This Huntress Is Bombarded With Death Threats From Online Trolls | Media Drum World" />
<meta property="og:description" content="The huntress is bombarded with death threats from online trolls who say she should be hunted like her animals are. Read more." />
<meta property="og:url" content="https://mediadrumworld.com/2020/09/10/death-threat-hunting-trolls/" />
<meta property="og:site_name" content="Media Drum World" />
<meta property="article:publisher" content="https://www.facebook.com/mediadrumworld/" />
<meta property="article:tag" content="animal" />
<meta property="article:tag" content="conservation" />
<meta property="article:tag" content="Death" />
<meta property="article:tag" content="death threats" />
<meta property="article:tag" content="hunting" />
<meta property="article:tag" content="huntress" />
<meta property="article:tag" content="lifestyle" />
<meta property="article:tag" content="online" />
<meta property="article:tag" content="trolls" />
<meta property="article:tag" content="welfare" />
<meta property="article:section" content="Popular" />
<meta property="article:published_time" content="2020-09-10T15:48:43+01:00" />
<meta property="og:image" content="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-5-1-scaled.jpg" />
<meta property="og:image:width" content="2399" />
<meta property="og:image:height" content="2560" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The huntress is bombarded with death threats from online trolls who say she should be hunted like her animals are. Read more." />
<meta name="twitter:title" content="This Huntress Is Bombarded With Death Threats From Online Trolls | Media Drum World" />
<meta name="twitter:site" content="@MediaDrumWorld" />
<meta name="twitter:image" content="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-5-1-scaled.jpg" />
<meta name="twitter:creator" content="@MediaDrumWorld" />
<meta property="DC.date.issued" content="2020-09-10T15:48:43+01:00" />
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Media Drum World &raquo; Feed" href="https://mediadrumworld.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Media Drum World &raquo; Comments Feed" href="https://mediadrumworld.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Media Drum World &raquo; This Huntress Is Bombarded With Death Threats From Online Trolls Comments Feed" href="https://mediadrumworld.com/2020/09/10/death-threat-hunting-trolls/feed/" />
		<script type="text/javascript">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</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://mediadrumworld.com/wp-includes/css/dist/block-library/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css'  href='https://mediadrumworld.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=819b7f9b02b0195f80e3eab970f44973x' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Source+Sans+Pro%3A400%7COpen+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900&#038;subset=latin-ext&#038;display=swap&#038;ver=10.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://mediadrumworld.com/wp-content/themes/Newspaper/style.css?ver=10.2' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='js_composer_front-css'  href='https://mediadrumworld.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=6.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='td-legacy-framework-front-style-css'  href='https://mediadrumworld.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=819b7f9b02b0195f80e3eab970f44973x' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css'  href='https://mediadrumworld.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=f3d6322e6f953bf07f46586e1d97917d' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://mediadrumworld.com/wp-content/plugins/td-composer/legacy/Newspaper/includes/demos/politics/demo_style.css?ver=10.2' type='text/css' media='all' />
<link rel='stylesheet' id='tdb_front_style-css'  href='https://mediadrumworld.com/wp-content/plugins/td-cloud-library/assets/css/tdb_less_front.css?ver=c8cba5620a72d5b299fa8f62aeca6adfx' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var IwNRCargs = {"rightclick":"Y","draganddrop":"Y"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mediadrumworld.com/wp-content/plugins/image-watermark/js/no-right-click.js?ver=1.6.6'></script>
<script type='text/javascript' src='https://mediadrumworld.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://mediadrumworld.com/wp-includes/js/jquery/jquery-migrate.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://mediadrumworld.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mediadrumworld.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mediadrumworld.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://mediadrumworld.com/?p=61484' />
<link rel="alternate" type="application/json+oembed" href="https://mediadrumworld.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmediadrumworld.com%2F2020%2F09%2F10%2Fdeath-threat-hunting-trolls%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mediadrumworld.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmediadrumworld.com%2F2020%2F09%2F10%2Fdeath-threat-hunting-trolls%2F&#038;format=xml" />
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
        <script>
        window.tdb_globals = {"wpRestNonce":"da63eed59d","wpRestUrl":"https:\/\/mediadrumworld.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/","isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
    			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/mediadrumworld.com\/wp-admin\/","wpRestNonce":"da63eed59d","wpRestUrl":"https:\/\/mediadrumworld.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};
			</script>
			<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>

<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>




<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://mediadrumworld.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://mediadrumworld.com/category/popular/",
                    "name": "Popular"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://mediadrumworld.com/2020/09/10/death-threat-hunting-trolls/",
                    "name": "This Huntress Is Bombarded With Death Threats From Online Trolls"                                
                }
            }    
        ]
    }
</script>
<link rel="icon" href="https://mediadrumworld.com/wp-content/uploads/2016/07/MDW-LOGO-FINAL-EMAIL-e1470217081277-150x150.jpg" sizes="32x32" />
<link rel="icon" href="https://mediadrumworld.com/wp-content/uploads/2016/07/MDW-LOGO-FINAL-EMAIL-e1470217081277.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://mediadrumworld.com/wp-content/uploads/2016/07/MDW-LOGO-FINAL-EMAIL-e1470217081277.jpg" />
<meta name="msapplication-TileImage" content="https://mediadrumworld.com/wp-content/uploads/2016/07/MDW-LOGO-FINAL-EMAIL-e1470217081277.jpg" />

<!-- Button style compiled by theme -->

<style>
    .tdm_block_column_content:hover .tdm-col-content-title-url .tdm-title,
                .tds-button2 .tdm-btn-text,
                .tds-button2 i,
                .tds-button5:hover .tdm-btn-text,
                .tds-button5:hover i,
                .tds-button6 .tdm-btn-text,
                .tds-button6 i,
                .tdm_block_list .tdm-list-item i,
                .tdm_block_pricing .tdm-pricing-feature i,
                .tdm-social-item i {
                    color: #d91b5c;
                }
                .tds-button1,
                .tds-button6:after,
                .tds-title2 .tdm-title-line:after,
                .tds-title3 .tdm-title-line:after,
                .tdm_block_pricing.tdm-pricing-featured:before,
                .tdm_block_pricing.tds_pricing2_block.tdm-pricing-featured .tdm-pricing-header,
                .tds-progress-bar1 .tdm-progress-bar:after,
                .tds-progress-bar2 .tdm-progress-bar:after,
                .tds-social3 .tdm-social-item {
                    background-color: #d91b5c;
                }
                .tds-button2:before,
                .tds-button6:before,
                .tds-progress-bar3 .tdm-progress-bar:after {
                  border-color: #d91b5c;
                }
                .tdm-btn-style1 {
					background-color: #d91b5c;
				}
				.tdm-btn-style2:before {
				    border-color: #d91b5c;
				}
				.tdm-btn-style2 {
				    color: #d91b5c;
				}
				.tdm-btn-style3 {
				    -webkit-box-shadow: 0 2px 16px #d91b5c;
                    -moz-box-shadow: 0 2px 16px #d91b5c;
                    box-shadow: 0 2px 16px #d91b5c;
				}
				.tdm-btn-style3:hover {
				    -webkit-box-shadow: 0 4px 26px #d91b5c;
                    -moz-box-shadow: 0 4px 26px #d91b5c;
                    box-shadow: 0 4px 26px #d91b5c;
				}
</style>

<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-61484 single-format-standard locale-en-gb td-standard-pack death-threat-hunting-trolls global-block-template-1 td-politics single_template_2 white-menu wpb-js-composer js-comp-ver-6.2.0 vc_responsive td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>

    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/mediadrumworld/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/mdwfeatures/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/MediaDrumWorld" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCr9ca4aRRLXTmIPkV9aVPeg" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="td-mobile-main-menu"><li id="menu-item-145" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first menu-item-145"><a href="https://mediadrumworld.com/category/wild/">Wild</a></li>
<li id="menu-item-143" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-143"><a href="https://mediadrumworld.com/category/travel-photography-videos/">Travel</a></li>
<li id="menu-item-136" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-136"><a href="https://mediadrumworld.com/category/aerial/">Aerial</a></li>
<li id="menu-item-135" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-135"><a href="https://mediadrumworld.com/category/lost/">Lost</a></li>
<li id="menu-item-137" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-137"><a href="https://mediadrumworld.com/category/art/">Art</a></li>
<li id="menu-item-144" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-144"><a href="https://mediadrumworld.com/category/water/">Water</a></li>
<li id="menu-item-138" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-138"><a href="https://mediadrumworld.com/category/ice/">Ice</a></li>
<li id="menu-item-139" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-139"><a href="https://mediadrumworld.com/category/past/">Past</a></li>
<li id="menu-item-1874" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1874"><a href="https://mediadrumworld.com/category/video/">VID</a></li>
<li id="menu-item-140" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-140"><a href="https://mediadrumworld.com/category/mdwfeatures/">MDWfeatures</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
            <div id="login-form-mobile" class="td-register-section">
            
            <div id="td-login-mob" class="td-login-animation td-login-hide-mob">
            	<!-- close button -->
	            <div class="td-login-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Sign in</div>
	                <!-- close button -->
		            <div class="td-mobile-close">
		                <a href="#"><i class="td-icon-close-mobile"></i></a>
		            </div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title"><span>Welcome!</span>Log into your account</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email-mob" value="" required><label>your username</label></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass-mob" value="" required><label>your password</label></div>
	                <input type="button" name="login_button" id="login_button-mob" class="td-login-button" value="LOG IN">
	                <div class="td-login-info-text">
	                <a href="#" id="forgot-pass-link-mob">Forgot your password?</a>
	                </div>
	                <div class="td-login-register-link">
	                
	                </div>
	                
	                

                </div>
            </div>

            
            
            
            
            <div id="td-forgot-pass-mob" class="td-login-animation td-login-hide-mob">
                <!-- close button -->
	            <div class="td-forgot-pass-close">
	                <a href="#" class="td-back-button"><i class="td-icon-read-down"></i></a>
	                <div class="td-login-title">Password recovery</div>
	            </div>
	            <div class="td-login-form-wrap">
	                <div class="td-login-panel-title">Recover your password</div>
	                <div class="td_display_err"></div>
	                <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email-mob" value="" required><label>your email</label></div>
	                <input type="button" name="forgot_button" id="forgot_button-mob" class="td-login-button" value="Send My Pass">
                </div>
            </div>
        </div>
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search">
		<form method="get" class="td-search-form" action="https://mediadrumworld.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>

    <div id="td-outer-wrap" class="td-theme-wrap">
    
        
            <div class="tdc-header-wrap ">

            <!--
Header style 5
-->


<div class="td-header-wrap td-header-style-5 ">
    
    <div class="td-header-top-menu-full td-container-wrap ">
        <div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	        <div class="td_data_time">
            <div >

                Saturday, September 12, 2020
            </div>
        </div>
    </div>
        <div class="td-header-sp-top-widget">
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/mediadrumworld/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/mdwfeatures/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/MediaDrumWorld" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCr9ca4aRRLXTmIPkV9aVPeg" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span>    </div>    </div>

<!-- LOGIN MODAL -->

                <div  id="login-form" class="white-popup-block mfp-hide mfp-with-anim">
                    <div class="td-login-wrap">
                        <a href="#" class="td-back-button"><i class="td-icon-modal-back"></i></a>
                        <div id="td-login-div" class="td-login-form-div td-display-block">
                            <div class="td-login-panel-title">Sign in</div>
                            <div class="td-login-panel-descr">Welcome! Log into your account</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="login_email" id="login_email" value="" required><label>your username</label></div>
	                        <div class="td-login-inputs"><input class="td-login-input" type="password" name="login_pass" id="login_pass" value="" required><label>your password</label></div>
                            <input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
                            <div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
                            
                            
                            
                            
                        </div>

                        

                         <div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
                            <div class="td-login-panel-title">Password recovery</div>
                            <div class="td-login-panel-descr">Recover your password</div>
                            <div class="td_display_err"></div>
                            <div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label>your email</label></div>
                            <input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
                            <div class="td-login-info-text">A password will be e-mailed to you.</div>
                        </div>
                        
                        
                    </div>
                </div>
                        </div>
    </div>

    <div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap ">
            <div class="td-container td-header-row td-header-main-menu black-menu">
                <div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-menu">
                    <a class="td-main-logo" href="https://mediadrumworld.com/">
                <img src="https://mediadrumworld.com/wp-content/uploads/2016/08/MDW-LOGO-FINAL-EMAIL.jpg" alt=""/>
                <span class="td-visual-hidden">Media Drum World</span>
            </a>
            </div>
    <div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="sf-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-first td-menu-item td-normal-menu menu-item-145"><a href="https://mediadrumworld.com/category/wild/">Wild</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-143"><a href="https://mediadrumworld.com/category/travel-photography-videos/">Travel</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-136"><a href="https://mediadrumworld.com/category/aerial/">Aerial</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-135"><a href="https://mediadrumworld.com/category/lost/">Lost</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-137"><a href="https://mediadrumworld.com/category/art/">Art</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-144"><a href="https://mediadrumworld.com/category/water/">Water</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-138"><a href="https://mediadrumworld.com/category/ice/">Ice</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-139"><a href="https://mediadrumworld.com/category/past/">Past</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-1874"><a href="https://mediadrumworld.com/category/video/">VID</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-140"><a href="https://mediadrumworld.com/category/mdwfeatures/">MDWfeatures</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://mediadrumworld.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
            </div>
        </div>
    </div>

            <div class="td-header-header-full td-banner-wrap-full td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-header tdi_1_c85 td_block_template_1 ">

<style>
/* custom css */
.tdi_1_c85.td-a-rec-img{
				    text-align: left;
				}.tdi_1_c85.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:980px;height:120px" data-ad-client="ca-pub-1834405831027832" data-ad-slot="8750006507"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1834405831027832" data-ad-slot="8750006507"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1834405831027832" data-ad-slot="8750006507"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-1834405831027832" data-ad-slot="8750006507"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 


</div>                </div>
            </div>
        </div>
    
</div>
            </div>

            
<div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-2">
        <article id="post-61484" class="post-61484 post type-post status-publish format-standard has-post-thumbnail category-popular tag-animal tag-conservation tag-death tag-death-threats tag-hunting tag-huntress tag-lifestyle tag-online tag-trolls tag-welfare" itemscope itemtype="https://schema.org/Article">
            <div class="td-pb-row">
                <div class="td-pb-span12">
                    <div class="td-post-header">
                        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://mediadrumworld.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Popular" class="entry-crumb" href="https://mediadrumworld.com/category/popular/">Popular</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">This Huntress Is Bombarded With Death Threats From Online Trolls</span></div></div>

                        
                        <header class="td-post-title">
                            <h1 class="entry-title">This Huntress Is Bombarded With Death Threats From Online Trolls</h1>

                            

                            <div class="td-module-meta-info">
                                                                                                <div class="td-post-views"><i class="td-icon-views"></i><span class="td-nr-views-61484">33</span></div>                                                            </div>

                        </header>
                    </div>
                </div>
            </div> <!-- /.td-pb-row -->

            <div class="td-pb-row">
                                        <div class="td-pb-span12 td-main-content" role="main">
                            <div class="td-ss-main-content">
                                
        <div class="td-post-sharing-top"></div>

        <div class="td-post-content">
            <div class="td-post-featured-image"><figure><a href="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-5-1-scaled.jpg" data-caption="Petra said her family is self-sufficient in terms of their meat intake thanks to hunting. MDWfeatures / @petrrissa"><img width="1068" height="1140" class="entry-thumb td-modal-image" src="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-5-1-1068x1140.jpg" srcset="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-5-1-1068x1140.jpg 1068w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-5-1-281x300.jpg 281w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-5-1-960x1024.jpg 960w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-5-1-768x820.jpg 768w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-5-1-1439x1536.jpg 1439w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-5-1-1919x2048.jpg 1919w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-5-1-696x743.jpg 696w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-5-1-394x420.jpg 394w" sizes="(max-width: 1068px) 100vw, 1068px" alt="" title="MDRUMF_Death_Threat_Huntress-5"/></a><figcaption class="wp-caption-text">Petra said her family is self-sufficient in terms of their meat intake thanks to hunting. MDWfeatures / @petrrissa</figcaption></figure></div>
            <p>By Kate Harrold</p>
<p>&nbsp;</p>
<p>THIS HUNTRESS is bombarded with DEATH THREATS from trolls who say she should be hunted down like her animals.</p>
<p>Forest engineer, Petra Krchňavá (31) from Vinica, Slovakia, has been hunting for over 13 years – this passion traversing several generations of her family. Having first been introduced to the activity by her father, Peter (56), when she was six, hunting has become more than just a hobby for Petra. It’s become a lifestyle.</p>
<p>Hunting has never been about the kill for Petra. Instead, she appreciates the sunrise, the dawn mist, the morning birdsong, and the time she gets to spend observing the animals. In fact, the welfare of the animals is Petra’s number one priority.</p>
 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_inline tdi_2_68e td_block_template_1 ">

<style>
/* custom css */
.tdi_2_68e.td-a-rec-img{
				    text-align: left;
				}.tdi_2_68e.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:980px;height:120px" data-ad-client="ca-pub-1834405831027832" data-ad-slot="6922922502"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1834405831027832" data-ad-slot="6922922502"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1834405831027832" data-ad-slot="6922922502"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:320px;height:50px" data-ad-client="ca-pub-1834405831027832" data-ad-slot="6922922502"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 


<figure id="attachment_61494" aria-describedby="caption-attachment-61494" style="width: 1920px" class="wp-caption alignnone"><img class="size-full wp-image-61494" src="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-3-1-scaled.jpg" alt="" width="1920" height="2560" srcset="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-3-1-scaled.jpg 1920w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-3-1-225x300.jpg 225w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-3-1-768x1024.jpg 768w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-3-1-1152x1536.jpg 1152w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-3-1-1536x2048.jpg 1536w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-3-1-696x928.jpg 696w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-3-1-1068x1424.jpg 1068w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-3-1-315x420.jpg 315w" sizes="(max-width: 1920px) 100vw, 1920px" /><figcaption id="caption-attachment-61494" class="wp-caption-text">Petra has been hunting for over 13 years although she was introduced to the hobby when she was six. MDWfeatures / @petrrissa</figcaption></figure>
<p>Petra has spent several thousand pounds contributing to conservation efforts. This money has been spent on feeding wild animals – which costs roughly £1800 (€2000) a fortnight &#8211; providing medicine, building lakes to counteract habitat destruction, embarking on litter pick-ups, and running educational programmes for young children.</p>
<p>Just last year, Petra and her father harvested a fallow deer that they’d been watching in their local hunting grounds for over nine years. It was only when this deer had passed on his genetic material that conservation efforts deemed him safe to hunt.</p>
<p>Hunting has allowed Petra’s family to become self-sufficient in their meat consumption. Every element of the animal is used leaving next to no waste. Despite this, Petra has faced several death threats online with online trolls commenting ‘I hope you die like that animal,’ and ‘I wish you’d shoot each other.’</p>
<figure id="attachment_61497" aria-describedby="caption-attachment-61497" style="width: 1920px" class="wp-caption alignnone"><img class="size-full wp-image-61497" src="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-6-scaled.jpg" alt="" width="1920" height="2560" srcset="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-6-scaled.jpg 1920w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-6-225x300.jpg 225w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-6-768x1024.jpg 768w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-6-1152x1536.jpg 1152w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-6-1536x2048.jpg 1536w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-6-696x928.jpg 696w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-6-1068x1424.jpg 1068w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-6-315x420.jpg 315w" sizes="(max-width: 1920px) 100vw, 1920px" /><figcaption id="caption-attachment-61497" class="wp-caption-text">Petra prepares for a day of hunting. MDWfeatures / @petrrissa</figcaption></figure>
<p>This isn’t the only challenge Petra has faced. During a hunt in 2019, a fellow hunter standing just 87 yards away from Petra was accidentally shot and died almost immediately. The horrifying scene, which echoed the sentiments of Petra’s online trolls, tested her strength and resolve.</p>
<p>For some time, Petra found it difficult to love hunting in the same way she had previously. However, her determination to protect animals for future generations prevailed and she continues to hunt to conserve and manage game numbers.</p>
<p>“Hunting is a way of life and a tradition in my family. We adapt our lives to fit alongside the hunting season,” Petra said.</p>
<figure id="attachment_61498" aria-describedby="caption-attachment-61498" style="width: 1920px" class="wp-caption alignnone"><img class="size-full wp-image-61498" src="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-7-scaled.jpg" alt="" width="1920" height="2560" srcset="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-7-scaled.jpg 1920w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-7-225x300.jpg 225w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-7-768x1024.jpg 768w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-7-1152x1536.jpg 1152w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-7-1536x2048.jpg 1536w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-7-696x928.jpg 696w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-7-1068x1424.jpg 1068w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-7-315x420.jpg 315w" sizes="(max-width: 1920px) 100vw, 1920px" /><figcaption id="caption-attachment-61498" class="wp-caption-text">Petra holds two hunting rifles. MDWfeatures / @petrrissa</figcaption></figure>
<p>“Hunting is never just about the hunt. There’s so much time, energy, and care that goes into it but most people don’t realise this.</p>
<p>“People have wished me the same death as the animals I’ve harvested. People think we kill animals for fun which is not the case at all.</p>
<p>“I’ve been told ‘I hope you die like that animal,’ and ‘I wish you’d shoot each other.’</p>
<figure id="attachment_61495" aria-describedby="caption-attachment-61495" style="width: 2232px" class="wp-caption alignnone"><img class="size-full wp-image-61495" src="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-4-1-scaled.jpg" alt="" width="2232" height="2560" srcset="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-4-1-scaled.jpg 2232w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-4-1-262x300.jpg 262w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-4-1-893x1024.jpg 893w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-4-1-768x881.jpg 768w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-4-1-1339x1536.jpg 1339w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-4-1-1786x2048.jpg 1786w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-4-1-696x798.jpg 696w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-4-1-1068x1225.jpg 1068w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-4-1-366x420.jpg 366w" sizes="(max-width: 2232px) 100vw, 2232px" /><figcaption id="caption-attachment-61495" class="wp-caption-text">Petra says her whole life revolves around the hunting season. MDWfeatures / @petrrissa</figcaption></figure>
<p>“They don’t see that I feed the animals to make sure they survive the winter. I distribute drinking water in summer and build feeding facilities. We dig lakes, give them medicine, save young and other injured animals, and organise waste collection outings.</p>
<p>“We teach children in schools and run educational summer camps. I’ve spent thousands of my own euros contributing to these efforts.</p>
<p>“Last year, me and my father harvested a nine-year-old fallow deer. We’d watched him grow up and when he’d handed over his genetic material, it was safe to hunt him.</p>
<figure id="attachment_61502" aria-describedby="caption-attachment-61502" style="width: 1080px" class="wp-caption alignnone"><img class="size-full wp-image-61502" src="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-11.jpg" alt="" width="1080" height="1350" srcset="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-11.jpg 1080w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-11-240x300.jpg 240w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-11-819x1024.jpg 819w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-11-768x960.jpg 768w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-11-696x870.jpg 696w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-11-1068x1335.jpg 1068w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-11-336x420.jpg 336w" sizes="(max-width: 1080px) 100vw, 1080px" /><figcaption id="caption-attachment-61502" class="wp-caption-text">Petra says that spending time in nature in guaranteed to make her day better. MDWfeatures / @petrrissa</figcaption></figure>
<p>“Hunters love nature – and hunting has been a way of life for thousands of years. The management of game numbers and sexual composition preserves the herd for future generations. We care and protect these beasts with humility.</p>
<p>“In fact, I’m working on my own clothing collection of which the proceeds will go towards rescuing the western capercaillie – a member of the grouse family with a declining population.</p>
<p>“Hunting is also a dangerous hobby. I once was stood next to a fellow hunter who was accidentally shot and died. It was difficult to continue to love hunting after such a difficult experience.”</p>
<figure id="attachment_61504" aria-describedby="caption-attachment-61504" style="width: 1066px" class="wp-caption alignnone"><img class="size-full wp-image-61504" src="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-13.jpg" alt="" width="1066" height="1600" srcset="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-13.jpg 1066w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-13-200x300.jpg 200w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-13-682x1024.jpg 682w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-13-768x1153.jpg 768w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-13-1023x1536.jpg 1023w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-13-696x1045.jpg 696w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-13-280x420.jpg 280w" sizes="(max-width: 1066px) 100vw, 1066px" /><figcaption id="caption-attachment-61504" class="wp-caption-text">Petra looks out over the lake as she holds her hunting rifle. MDWfeatures / @petrrissa</figcaption></figure>
<p>The time spent alone in nature helped to rekindle Petra’s passion. She now hopes to continue educating young people on the benefits of conservation through hunting.</p>
<p>“I love enjoying the early morning sunrise, the birdsong, the magic fog, the silence – all whilst watching the animals,” Petra said.</p>
<p>“Being alone in nature with just my thoughts always seems to make my day better. Hunting has also brought me strength, courage, and some incredible friendships.</p>
<figure id="attachment_61506" aria-describedby="caption-attachment-61506" style="width: 1080px" class="wp-caption alignnone"><img class="size-full wp-image-61506" src="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-15.jpg" alt="" width="1080" height="1350" srcset="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-15.jpg 1080w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-15-240x300.jpg 240w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-15-819x1024.jpg 819w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-15-768x960.jpg 768w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-15-696x870.jpg 696w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-15-1068x1335.jpg 1068w, https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-15-336x420.jpg 336w" sizes="(max-width: 1080px) 100vw, 1080px" /><figcaption id="caption-attachment-61506" class="wp-caption-text">Petra doesn&#8217;t waste any of the meat from her hunts. MDWfeatures / @petrrissa</figcaption></figure>
<p>“When we process the game meat, it’s something shared by family, friends, and our village. It’s the healthiest meat a person can eat. There are no toxic products used. I know exactly what happened to that animal.</p>
<p>“During the current coronavirus crisis, we’ve been able to be self-sufficient when the supermarkets were empty.</p>
<p>“I’ve had people reach out to me to thank me for what I do for nature. Adults sometimes ask me how we can pass this message on to young people too.</p>
<p>“It’s important that we preserve nature for future generations. I hope I can teach my own child this one day.”</p>

 <!-- A generated by theme --> 

<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><div class="td-g-rec td-g-rec-id-content_bottom tdi_3_555 td_block_template_1 ">

<style>
/* custom css */
.tdi_3_555.td-a-rec-img{
				    text-align: left;
				}.tdi_3_555.td-a-rec-img img{
                    margin: 0 auto 0 0;
                }
</style><script type="text/javascript">
var td_screen_width = window.innerWidth;

                    if ( td_screen_width >= 1140 ) {
                        /* large monitors */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1834405831027832" data-ad-slot="1155590508"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
            
	                    if ( td_screen_width >= 1019  && td_screen_width < 1140 ) {
	                        /* landscape tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1834405831027832" data-ad-slot="1155590508"></ins>');
	                        (adsbygoogle = window.adsbygoogle || []).push({});
	                    }
	                
                    if ( td_screen_width >= 768  && td_screen_width < 1019 ) {
                        /* portrait tablets */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:468px;height:60px" data-ad-client="ca-pub-1834405831027832" data-ad-slot="1155590508"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                
                    if ( td_screen_width < 768 ) {
                        /* Phones */
                        document.write('<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-1834405831027832" data-ad-slot="1155590508"></ins>');
                        (adsbygoogle = window.adsbygoogle || []).push({});
                    }
                </script>
</div>

 <!-- end A --> 

        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://mediadrumworld.com/2020/09/10/death-threat-hunting-trolls/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:auto; height:21px; background-color:transparent;"></iframe></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://mediadrumworld.com/2020/09/10/woman-loses-weight-too-fat-for-ride/">This Woman Lost Nine Stone After Being Turned Away From A Theme Park Ride For Being Too Fat</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://mediadrumworld.com/2020/09/10/tribe-women-elongate-necks-five-years-old/">These Tribal Women Elongate Their Necks From Just Five Years Of Age To Appear Less Attractive To Other Tribes</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://mediadrumworld.com/author/picturedesk/">Courtney McHugh</a></span></div>	        <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Courtney McHugh"></span><meta itemprop="datePublished" content="2020-09-10T15:48:43+01:00"><meta itemprop="dateModified" content="2020-09-10T15:48:43+01:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://mediadrumworld.com/2020/09/10/death-threat-hunting-trolls/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://mediadrumworld.com/wp-content/uploads/2016/08/MDW-LOGO-FINAL-EMAIL.jpg"></span><meta itemprop="name" content="Media Drum World"></span><meta itemprop="headline " content="This Huntress Is Bombarded With Death Threats From Online Trolls"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Death_Threat_Huntress-5-1-scaled.jpg"><meta itemprop="width" content="2399"><meta itemprop="height" content="2560"></span>        </footer>

    <div class="td_block_wrap td_block_related_posts td-related-full-width tdi_4_1c2 td_with_ajax_pagination td-pb-border-top td_block_template_1"  data-td-block-uid="tdi_4_1c2" ><script>var block_tdi_4_1c2 = new tdBlock();
block_tdi_4_1c2.id = "tdi_4_1c2";
block_tdi_4_1c2.atts = '{"limit":5,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td-related-full-width tdi_4_1c2","td_column_number":5,"live_filter_cur_post_id":61484,"live_filter_cur_post_author":"2","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_4_1c2","tdc_css_class_style":"tdi_4_1c2_rand_style"}';
block_tdi_4_1c2.td_column_number = "5";
block_tdi_4_1c2.block_type = "td_block_related_posts";
block_tdi_4_1c2.post_count = "5";
block_tdi_4_1c2.found_posts = "546";
block_tdi_4_1c2.header_color = "";
block_tdi_4_1c2.ajax_pagination_infinite_stop = "";
block_tdi_4_1c2.max_num_pages = "110";
tdBlocksArray.push(block_tdi_4_1c2);
</script><h4 class="td-related-title td-block-title"><a id="tdi_5_bfb" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_4_1c2" href="#">RELATED ARTICLES</a><a id="tdi_6_989" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_4_1c2" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_4_1c2 class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mediadrumworld.com/2020/09/10/woman-loses-weight-too-fat-for-ride/" rel="bookmark" class="td-image-wrap" title="This Woman Lost Nine Stone After Being Turned Away From A Theme Park Ride For Being Too Fat"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="This Woman Lost Nine Stone After Being Turned Away From A Theme Park Ride For Being Too Fat" data-type="image_tag" data-img-url="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_ROLLERCOASTER_FATTY-16-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://mediadrumworld.com/category/mdwfeatures/" class="td-post-category">MDWfeatures</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mediadrumworld.com/2020/09/10/woman-loses-weight-too-fat-for-ride/" rel="bookmark" title="This Woman Lost Nine Stone After Being Turned Away From A Theme Park Ride For Being Too Fat">This Woman Lost Nine Stone After Being Turned Away From A Theme Park Ride For Being Too Fat</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mediadrumworld.com/2020/09/10/allergic-reaction-diy-hair-dye/" rel="bookmark" class="td-image-wrap" title="This Woman&#8217;s Face Ballooned And She Had To Shave Her Head After An Allergic Reaction To Hair Dye"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="This Woman&#8217;s Face Ballooned And She Had To Shave Her Head After An Allergic Reaction To Hair Dye" data-type="image_tag" data-img-url="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Bad_Hair_Dye-6-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://mediadrumworld.com/category/mdwfeatures/" class="td-post-category">MDWfeatures</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mediadrumworld.com/2020/09/10/allergic-reaction-diy-hair-dye/" rel="bookmark" title="This Woman&#8217;s Face Ballooned And She Had To Shave Her Head After An Allergic Reaction To Hair Dye">This Woman&#8217;s Face Ballooned And She Had To Shave Her Head After An Allergic Reaction To Hair Dye</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mediadrumworld.com/2020/09/10/man-spends-day-applying-makeup-look-like-ken-doll/" rel="bookmark" class="td-image-wrap" title="This Man Spends Four Hours A Day Applying Makeup To Look Like A Real-Life Ken Doll"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="This Man Spends Four Hours A Day Applying Makeup To Look Like A Real-Life Ken Doll" data-type="image_tag" data-img-url="https://mediadrumworld.com/wp-content/uploads/2020/09/hqdefault-218x150.jpg"  width="218" height="150" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://mediadrumworld.com/category/mdwfeatures/" class="td-post-category">MDWfeatures</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mediadrumworld.com/2020/09/10/man-spends-day-applying-makeup-look-like-ken-doll/" rel="bookmark" title="This Man Spends Four Hours A Day Applying Makeup To Look Like A Real-Life Ken Doll">This Man Spends Four Hours A Day Applying Makeup To Look Like A Real-Life Ken Doll</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mediadrumworld.com/2020/09/10/eczema-severe-bedbound/" rel="bookmark" class="td-image-wrap" title="This Woman&#8217;s Eczema Was So Severe It Left Her Bedbound"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="This Woman&#8217;s Eczema Was So Severe It Left Her Bedbound" data-type="image_tag" data-img-url="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_ROTTEN_FLESH_ECZEMA-7-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://mediadrumworld.com/category/mdwfeatures/" class="td-post-category">MDWfeatures</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mediadrumworld.com/2020/09/10/eczema-severe-bedbound/" rel="bookmark" title="This Woman&#8217;s Eczema Was So Severe It Left Her Bedbound">This Woman&#8217;s Eczema Was So Severe It Left Her Bedbound</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mediadrumworld.com/2020/09/03/female-naturist-insists-nudity-isnt-sexual/" rel="bookmark" class="td-image-wrap" title="This Female Naturist Insists Nudity Isn&#8217;t Sexual"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAANoAAACWAQMAAACCSQSPAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAABpJREFUWMPtwQENAAAAwiD7p7bHBwwAAAAg7RD+AAGXD7BoAAAAAElFTkSuQmCC" alt="" title="This Female Naturist Insists Nudity Isn&#8217;t Sexual" data-type="image_tag" data-img-url="https://mediadrumworld.com/wp-content/uploads/2020/09/MDRUMF_Naked_Attraction-8-218x150.jpg"  width="218" height="150" /></a></div>                <a href="https://mediadrumworld.com/category/mdwfeatures/" class="td-post-category">MDWfeatures</a>            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://mediadrumworld.com/2020/09/03/female-naturist-insists-nudity-isnt-sexual/" rel="bookmark" title="This Female Naturist Insists Nudity Isn&#8217;t Sexual">This Female Naturist Insists Nudity Isn&#8217;t Sexual</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-tdi_4_1c2" data-td_block_id="tdi_4_1c2"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-tdi_4_1c2" data-td_block_id="tdi_4_1c2"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
    <div class="comments" id="comments">
        	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/09/10/death-threat-hunting-trolls/#respond" style="display:none;">Cancel reply</a></small></h3><p class="must-log-in td-login-comment"><a class="td-login-modal-js" data-effect="mpf-td-login-effect" href="#login-form">Log in to leave a comment </a></p>	</div><!-- #respond -->
	    </div> <!-- /.content -->
                                </div>
                        </div>
                                    </div> <!-- /.td-pb-row -->
        </article> <!-- /.post -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->




	<!-- Footer -->
	<div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-14 ">
    <div class="td-container td-footer-bottom-full">
        <div class="td-pb-row">
            <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://mediadrumworld.com/"><img src="https://mediadrumworld.com/wp-content/uploads/2016/08/MDW-LOGO-FINAL-EMAIL.jpg" alt="Media Drum World - Bringing you the wonders of our planet" title=""/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Media Drum World is a British-based Press Agency and bespoke media content supplier. We specialise in international picture-video syndication, retail print sales and the productions of real-life feature stories.

<div class="footer-email-wrap">Contact us: <a href="mailto:editorial@mediadrumworld.com">editorial@mediadrumworld.com</a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.facebook.com/mediadrumworld/" title="Facebook">
                <i class="td-icon-font td-icon-facebook"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.instagram.com/mdwfeatures/" title="Instagram">
                <i class="td-icon-font td-icon-instagram"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/MediaDrumWorld" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://www.youtube.com/channel/UCr9ca4aRRLXTmIPkV9aVPeg" title="Youtube">
                <i class="td-icon-font td-icon-youtube"></i>
            </a>
        </span></aside></div>        </div>
    </div>
</div>
	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-55779" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-55779"><a href="https://mediadrumworld.com/about-media-drum-world/">About / Contact Us</a></li>
<li id="menu-item-46538" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-46538"><a href="https://mediadrumworld.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-275" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-275"><a href="https://mediadrumworld.com/category/lost/">Lost</a></li>
<li id="menu-item-276" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-276"><a href="https://mediadrumworld.com/category/aerial/">Aerial</a></li>
<li id="menu-item-277" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-277"><a href="https://mediadrumworld.com/category/art/">Art</a></li>
<li id="menu-item-278" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-278"><a href="https://mediadrumworld.com/category/ice/">Ice</a></li>
<li id="menu-item-279" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-279"><a href="https://mediadrumworld.com/category/past/">Past</a></li>
<li id="menu-item-280" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-280"><a href="https://mediadrumworld.com/category/mdwfeatures/">MDWfeatures</a></li>
<li id="menu-item-282" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-282"><a href="https://mediadrumworld.com/category/travel-photography-videos/">Travel</a></li>
<li id="menu-item-283" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-283"><a href="https://mediadrumworld.com/category/water/">Water</a></li>
<li id="menu-item-284" class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-284"><a href="https://mediadrumworld.com/category/wild/">Wild</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Media Drum Ltd 2016.  All rights reserved.     Logo by wearestamp.co.uk.                </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->


                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">MORE STORIES</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_1 td_module_wrap td-animation-stack">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://mediadrumworld.com/2019/02/27/period-blood-pride/" rel="bookmark" class="td-image-wrap" title="The Way This Sex Coach Embraces Her Period Leaves A Lot Of People Red Faced"><img class="entry-thumb" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAUQAAACgAQMAAABOhoelAAAAA1BMVEWurq51dlI4AAAAAXRSTlMmkutdmwAAAB1JREFUWMPtwTEBAAAAwiD7p/ZdCGAAAAAAAAAQBxpAAAH8le3bAAAAAElFTkSuQmCC" alt="" title="The Way This Sex Coach Embraces Her Period Leaves A Lot Of People Red Faced" data-type="image_tag" data-img-url="https://mediadrumworld.com/wp-content/uploads/2019/02/sddefault-31-324x160.jpg"  width="324" height="160" /><span class="td-video-play-ico"><i class="td-icon-video-thumb-play"></i></span></a></div>                <a href="https://mediadrumworld.com/category/mdwfeatures/" class="td-post-category">MDWfeatures</a>            </div>
            <h3 class="entry-title td-module-title"><a href="https://mediadrumworld.com/2019/02/27/period-blood-pride/" rel="bookmark" title="The Way This Sex Coach Embraces Her Period Leaves A Lot Of People Red Faced">The Way This Sex Coach Embraces Her Period Leaves A Lot...</a></h3>
            <div class="td-module-meta-info">
                <span class="td-post-author-name"><a href="https://mediadrumworld.com/author/picturedesk/">Courtney McHugh</a> <span>-</span> </span>                <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-02-27T12:39:10+00:00" >27th February 2019</time></span>                <span class="td-module-comments"><a href="https://mediadrumworld.com/2019/02/27/period-blood-pride/#respond">0</a></span>            </div>

            
        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv.com 2019
        Version: 10.2 (rara)
        Deploy mode: deploy
        
        uid: 5f5c58988c1f7
    -->

    
<!-- Custom css from theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
.td_block_18 .td_module_mx8 .td-module-thumb a:last-child:after {
opacity: 0;
}
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-73754658-2', 'auto');
  ga('send', 'pageview');

.td-category-description p{
color:black!important;
font-style:initial!important;
}

</style>

<script type='text/javascript' src='https://mediadrumworld.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script>
<script type='text/javascript' src='https://mediadrumworld.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=c8cba5620a72d5b299fa8f62aeca6adfx'></script>
<script type='text/javascript' src='https://mediadrumworld.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=10.2'></script>
<script type='text/javascript' src='https://mediadrumworld.com/wp-includes/js/comment-reply.js?ver=5.4.2'></script>
<script type='text/javascript' src='https://mediadrumworld.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=c8cba5620a72d5b299fa8f62aeca6adfx'></script>
<script type='text/javascript' src='https://mediadrumworld.com/wp-includes/js/wp-embed.js?ver=5.4.2'></script>

<!-- JS generated by theme -->

<script>
    
</script>


</body>
</html>